php_phalcon.dll not loaded by wampserver 2.5 x64, no errors to explain why.

Summerizing: downloaded and activated correct php_phalcon.dll yet php doesn't load it and doesn't provide any errors about it.

Windows 7 Home Premium 64-bit OS WampServer Version 2.5 (x64) Apache Version :2.4.9 PHP Version :5.5.12 Compiler: MSVC11 (Visual C++ 2012) Thread Safety: enabled

Based on this information I downloaded this Phalcon.dll file: Phalcon 2.0.7 - Windows x64 for PHP 5.5.0 (vc11) Activated in php.ini: extension=php_phalcon.dll located in the ext directory where all the other php modules are located: C:\wamp\bin\php\php5.5.12\ext

Noticable is that in the PHP extension selector in the wampserver admin tool, the phalcon module has an exclamation mark inside a red triangle.
I wish there was some information attached to that.

Anyone with ideas how to get more information about why it doesn't load?

update: I tried the phalcon module for php 5.6.0, which resulted in readable pop-ups and errors in php_error.log so it does report wrong modules being loaded by php. Any suggestions welcome at this point.

update2: Problem found. phpinfo showed that php uses: C:\wamp\bin\apache\apache2.4.9\bin\php.ini while I was focussed on: C:\wamp\bin\php\php5.5.12\php.ini I added "extension=php_phalcon.dll" to: C:\wamp\bin\apache\apache2.4.9\bin\php.ini It works now.

:) Well done!