Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Camel Case Controller

I have a weird issue where my camel case controller "AuthEventsController" dispatches correctly on my dev environment (centos) but not my production env (amazon-linux). From what I've read it shouldnt dispatch without some modification to the dispatcher. But why is this working on centos but not amazon-linux? Is there something in the different nginx/php packages that might affect this?

edited Sep '15

I think I discovered my problem. For AuthEventsController both /auth-events and /auth_events work correctly but /authevents only worked on my local centos vm not amazon-linux.

Although my site is served from the centos vm, Im using a vagrant shared folder thats mounting the osx host folder, case-insensitive. I assume this is why it let me do /authevents locally. Hope this helps someone else with a similar setup avoid the confusion.