Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Composer problem

I use Phalcon 2.1 beta and I have little problem with devtools. I installed my composer.json:

"require": { "php": ">=5.6", "ext-phalcon": ">=2.1", "swiftmailer/swiftmailer": "v5.4.1", "snowair/phalcon-debugbar": "v1.1.16", "phalcon/incubator": "v2.0.7", "vegas-cmf/validation": "v2.0.0", "wisembly/": "v3.0.0", "sidroberts/phalcon-cron": "dev-master", "phpunit/phpunit": "4.8" }

and when I run: phalcon migration run I got such error:

PHP Fatal error: Class 'Doctrine\ORM\Tools\Setup' not found in /var/www/vendor/maximebf/debugbar/demo/bridge/doctrine/bootstrap.php on line 10

Next I removed /vendor, run command again and there is not such problem. My webapplication also works fine, there is problem only with devtools.


I don't think it has to do anything with phalcon or phalcon-devtools: As you can see, they don't use doctrine anywhere.

Also, phalcon-devtools has it's own autoloader and doesn't depend on composer.

Then probably it is caussed by one composer package, thanks!