We are moving our forum in GitHub Discussions. For questions about Phalcon v3/v4 you can visit here and for Phalcon v5 here.

Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Newbie Installing Phalcon for the first time

Trying to install phalcon for the first time on my mac (Mac OS X Lion 10.7.5), I know there are other discussions that address the same issue, but I'm still having trouble:

sudo ./install

Configuring for: PHP Api Version: 20121113 Zend Module Api No: 20121212 Zend Extension Api No: 220121212 ./install: line 69: aclocal: command not found

The requirements state that you must have git installed and GCC complier, I am using php 5.5. I installed the command line tools in xcode for the gcc compiler.

Other discussions say I need libtools. I try libtools --version, and it looks like I don't have that and I try to install but not having success. Either please help install libtools, or find another way. Thank you in advance!



596
Accepted
answer

Ok, so I figured out what was going on. For anyone in the future having the same issue. I used brew. And made sure the following was up to date: Autoconf, Automake and Libtool

Example: to install one of the packages... I used the command: brew install Autoconf

I hope this information becomes useful to a programmer that wants to use phalcon on mac.