Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Phalcon on Centos 7 and Plesk 12

Hello @all,

i have a Centos vServer with different php versions. The standard version is 5.4.14 and here is phalcon 2.0.10 installed, but on the custom php version 5.6.19 it is not.

In opt/plesk/php/5.6/etc/php.d/, i have created the phalcon.ini and in etc/cphalcon/ is phalcon

Thank you for your help



Did you compiled Phalcon yet? if you have .so binary, just link to it from your php modules.

You need to compile for each php version.


Hi stamster,

thank you for your reply.

The is in /etc/cphalcon/build/64bits/modules/

I think it is compiled.

In my phalcon.ini is extension =




Hi Wojciech Ślawski,

also thank you.

Can you give me an example? Have i got to go into the php 5.6 directory for that?

In my php.ini of php 5.6 is also the extension = included.



edited Apr '16

Well you need to switch your php cli to php 5.6.x and compile phalcon with it, it will be stored somewhere under opt/plesk/php/5.6/etc/php.d/ i guess. But if it will overwrite /etc/cphalcon/build/64bits/modules/ then you need to create seperated folders for each php version. For each minor version of php (5.x 7.x etc) you need seperated phalcon version.

Well you have plesk. I don't know how to switch to another php version, im using phpbrew for such a things.


So i have changed the cli and now is the standard php version 5.6.19.

Thx to all :-)