Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Phalcon extension not loaded on a MAC OS

Hello Guys.

I have installed phalcon with instruction but it doesn't work for me.

For first I have installed XAMPP with PHP Version 7.0.8 After that I compile the phalcon:

git clone --depth=1 git:// cd cphalcon/build sudo ./install

Then I checked in phpinfo() Loaded Configuration File: /Applications/XAMPP/xamppfiles/etc/php.ini and I have added "" to /Applications/XAMPP/xamppfiles/etc/php.ini

but after restart the webserver the extension is not added in phpinfo()

please help me.

And what webserver you are using ?

XAMPP 7.0.8-0


this does not work for me ((


Check in your terminal: php --version

You can check the path with: which php

and check in your browser with a phpinfo.php file which php version you have. Maybe you have loaded the system php and not the xampp php

After check in terminal:

php --version:

PHP 7.0.9 (cli) (built: Jul 21 2016 14:50:47) ( NTS )

Copyright (c) 1997-2016 The PHP Group

Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies

which php:


and check in browser a phpinfo.php file:

PHP Version 7.0.8

edited Aug '16

So i guess phalcon was installed only for cli. Your xampp has seperated php handler.

Do you have some ideas how to fix it?

edited Aug '16

Find path of php xampp handler and link it ? Or just remove xampp totally and just work on php built-in already. Or easier:

remove both php and xampp and install only one if you want to use xampp.


on mac, it's more simple using Brew to install php and phalcon up to 2.x, for phalcon 3 you need to compile it from source


So you have 2 different php versions. 7.0.9 and 7.0.8.

Normally you don't need xampp on MAC, because apache is preinstalled on any MAC.

What i did on my MAC:

Download from here:

Check this dir: /usr/local/php5

Your php ini will be located at /usr/local/php5/php.d/99-liip-developer.ini

To make this PHP available on CLI (Command Line Interface) pls also add php to your .profile file with export PATH=/usr/local/php5/bin:$PATH

Change PHP version. Simply change the symlink ‘php5’ to the desired PHP path in /usr/local/ by //PHP 5.6

cd /usr/local
rm -R php5
sudo ln -s php5-5.6.23-20160626-132038  php5
sudo apachectl restart

//PHP 7.0

cd /usr/local
rm -R php5
sudo ln -s php5-7.0.8-20160626-123411  php5
sudo apachectl restart

Hope it helps :-)


Thanks guys, i fix this problem. Problem was is very easy.

Insted need was write full path extension="/usr/local/opt/php70-phalcon/"

I am very happy.