We have moved our forum to GitHub Discussions. For questions about Phalcon v3/v4/v5 you can visit here and for Phalcon v6 here.


Hi, I am using composer.json for autoload, but after upgrading phalcon to 1.3.0 i have got problem

./composer.phar update

Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

Problem 1

  • Installation request for phalcon/incubator 1.3.0.x-dev -> satisfiable by phalcon/incubator[1.3.0.x-dev].
  • phalcon/incubator 1.3.0.x-dev requires ext-phalcon 1.3.0 -> the requested PHP extension phalcon is missing from your system.

my composer.json

    "require": {
        "php": ">=5.3.6",
        "phalcon/incubator": "1.3.0.x-dev"
    "autoload": {
        "classmap": ["models/","controllers/","controller_base/","plugins/","forms/"],
        "files": ["library/lib.php"],
        "psr-0" : {

Can you verify your phalcon version:

echo phpversion( "phalcon" );

I have a similar issue. Composer.json is:

{ "require": { "phalcon/incubator": "v1.2.5" } }

Message I receive after running composer is:

  • Installation request for Phalcon/incubator v1.2.5 -> satisfiable by phalcon/incubator(v1.2.5)
  • phalcon/incubator v1.2.5 requires ext-phalcon 1.2.5 -> the requested PHP extension phalcon is missing from your system.

When I run a phpinfo() command for the same project folder, it tells me that the phalcon extension 1.2.6 is loaded.

Should i be able to use the Phalcon/Incubator 1.2.5 package with the phalcon extension 1.2.6 ?

Can you try changing your composer.json to do this:

"require" : {
        "phalcon/incubator": "dev-master"

I'm not sure why it's giving you that error about ext-phalcon not being loaded. Try changing composer to dev-master and see if that helps.

Side note : composer can also check the Phalcon extension is actually loaded :

"require" : {
    "ext-phalcon": "3.4.*"