Phalcon on Raspberry Pi 3

Hello everyone !

I have a beautiful lamp server on my raspberry Pi 3 (which has the latest rapsbian version). Everything is working perfectly but now I want to add Phalcon. I saw a lot of posts where it is possible (https://forum.phalcon.io/discussion/13355/raspberry-pi-php-7-and-phalcon-3x for example) so I tried and followed all the instructions for a debian distrib (https://phalcon.io/fr/download/linux)

So I did the first steps correctly.

curl -s "https://packagecloud.io/install/repositories/phalcon/stable/script.deb.sh" | sudo bash
sudo apt-get install php7.0-phalcon

When I try to install php7.0-phalcon I don't have anything good. Only errors :

[email protected]:~ $ sudo apt-get install php7.0-phalcon
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet php7.0-phalcon
E: Couldn't find any package by glob 'php7.0-phalcon'
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « pp7.0-phalcon »

Someone has the answer of this problem ?

Have a nice day,

Thanks

You're installing a package meant for debian, on Raspbian. While Raspbian is based on Debian, it's not identical. You may need to compile from source on your Pi.