Problem with basic installation (Invo)

Hi,

I upgraded my Mac to Catalina and since then, I've got issues with my phalcon installation.

Here is my setup :

Apache 2.4.41 PHP 7.4.1 Phalcon 4

The problem is when I run vivo sample application, I always get Page Not Found exception. Apache error log :

Invo\Controllers\InvoController handler class cannot be loaded\n#0 [internal function]: Phalcon\Mvc\Dispatcher->throwDispatchException('Invo\\Controller...', 2)\n#1 [internal function]: Phalcon\Dispatcher\AbstractDispatcher->dispatch()\n#2 /Library/WebServer/Documents/invo/public/index.php(43): Phalcon\Mvc\Application->handle('/invo/')\n#3 {main}

It seems that the routing is not working. I don't know where to look anymore. I did lot of test and I can't figured out what is wrong.

Here is my Apache config file :

<Directory> AllowOverride none Require all denied </Directory>

DocumentRoot "/Library/WebServer/Documents" <Directory "/Library/WebServer/Documents"> Options FollowSymLinks Indexes AllowOverride All Require all granted </Directory>

Any help will be very appreciated.

try reinstalling your stack and updateing any dependencies



29.7k
edited Mar '20

try reinstalling your stack and updateing any dependencies

Hi, I already did that. I also build a stack on a ubuntu server with the exact same result. I followed the instructions in Phalcon documentation.



5.8k

i don't know if its the same but i had an issue after upgrading my mac

i made a lot of changes ( i use mamp )

i moved my DocumentRoot from desktop to /Users/user_name/www/ and it worked