Install phalcon dev tools 3.4

How can I install phalcon dev-tools 3.4 instead of 4 ?

My phalcon extension is v3.4.5 , installed this version because version 4 has some problems with Ubuntu.

So these are the steps I did

a. I git cloned from their official repo https://github.com/phalcon/phalcon-devtools.git

b. Checked out to remotes/origin/3.4.x , git checkout -b remotes/origin/3.4.x

c. Then I run composer install, but I get the following error :

  • The requested PHP extension ext-phalcon ^4.0.0 has the wrong version (3.4.5) installed. Install or enable PHP's phalcon extension.

Kindly advise.

Thank you



5.2k
edited Apr '20
composer require phalcon/devtools:3.4.12

or

you can clone it from here and then add it your path:

https://github.com/phalcon/phalcon-devtools/tree/v3.4.12

also check the discussion here if you ran into the handler class cannot be loaded issue