Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Install phalcon devtools on ubuntu

i've just start phalcon devtools installation usit git :

cd ~ git clone https://github.com/phalcon/phalcon-devtools.git cd phalcon-devtools

cd phalcon-devtools ln -s $(pwd)/phalcon /usr/bin/phalcon chmod ugo+x /usr/bin/phalcon

alias phalcon=/home/akbar/phalcon-devtools/phalcon

but when i run : $ phalcon

this error appear on terminal : ERROR: Please run composer install

and after running composer install , this is the result : PHP Warning: Module 'psr' already loaded in Unknown on line 0 PHP Warning: Module 'phalcon' already loaded in Unknown on line 0 Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

Problem 1

- codeception/codeception 3.1.0 requires facebook/webdriver ^1.6.0 -> satisfiable by facebook/webdriver[1.6.0, 1.7.0, 1.7.1].
- codeception/codeception 3.1.1 requires facebook/webdriver ^1.6.0 -> satisfiable by facebook/webdriver[1.6.0, 1.7.0, 1.7.1].
- codeception/codeception 3.1.2 requires facebook/webdriver ^1.6.0 -> satisfiable by facebook/webdriver[1.6.0, 1.7.0, 1.7.1].
- facebook/webdriver 1.7.1 requires ext-zip * -> the requested PHP extension zip is missing from your system.
- facebook/webdriver 1.7.0 requires ext-zip * -> the requested PHP extension zip is missing from your system.
- facebook/webdriver 1.6.0 requires ext-zip * -> the requested PHP extension zip is missing from your system.
- Installation request for codeception/codeception ^3.1 -> satisfiable by codeception/codeception[3.1.0, 3.1.1, 3.1.2].

To enable extensions, verify that they are enabled in your .ini files:

  • /etc/php/7.4/cli/php.ini
  • /etc/php/7.4/cli/conf.d/10-opcache.ini
  • /etc/php/7.4/cli/conf.d/10-pdo.ini
  • /etc/php/7.4/cli/conf.d/15-xml.ini
  • /etc/php/7.4/cli/conf.d/20-calendar.ini
  • /etc/php/7.4/cli/conf.d/20-ctype.ini
  • /etc/php/7.4/cli/conf.d/20-curl.ini
  • /etc/php/7.4/cli/conf.d/20-dom.ini
  • /etc/php/7.4/cli/conf.d/20-exif.ini
  • /etc/php/7.4/cli/conf.d/20-ffi.ini
  • /etc/php/7.4/cli/conf.d/20-fileinfo.ini
  • /etc/php/7.4/cli/conf.d/20-ftp.ini
  • /etc/php/7.4/cli/conf.d/20-gettext.ini
  • /etc/php/7.4/cli/conf.d/20-iconv.ini
  • /etc/php/7.4/cli/conf.d/20-json.ini
  • /etc/php/7.4/cli/conf.d/20-mbstring.ini
  • /etc/php/7.4/cli/conf.d/20-phar.ini
  • /etc/php/7.4/cli/conf.d/20-posix.ini
  • /etc/php/7.4/cli/conf.d/20-readline.ini
  • /etc/php/7.4/cli/conf.d/20-shmop.ini
  • /etc/php/7.4/cli/conf.d/20-simplexml.ini
  • /etc/php/7.4/cli/conf.d/20-sockets.ini
  • /etc/php/7.4/cli/conf.d/20-sysvmsg.ini
  • /etc/php/7.4/cli/conf.d/20-sysvsem.ini
  • /etc/php/7.4/cli/conf.d/20-sysvshm.ini
  • /etc/php/7.4/cli/conf.d/20-tokenizer.ini
  • /etc/php/7.4/cli/conf.d/20-xmlreader.ini
  • /etc/php/7.4/cli/conf.d/20-xmlwriter.ini
  • /etc/php/7.4/cli/conf.d/20-xsl.ini
  • /etc/php/7.4/cli/conf.d/50-phalcon.ini You can also run php --ini inside terminal to see which files are used by PHP in CLI mode.

can u help me please, thank you by the way.



6.6k
Accepted
answer

make sure you have ext-zip is enabled in your php.ini

make sure you have ext-zip is enabled in your php.ini

thank you my friend, it works !