Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Segmentation fault when using $this->security->hash($password)


Has anyone experienced this or something similiar or have any idea on what it might be?

I'm trying to hash a password using Phalcon\Security but it is causing an error.

I'm getting:

[Tue May 06 16:37:09.826577 2014] [core:notice] [pid 4740:tid 140735168942864] AH00052: child pid 7756 exit signal Bus error (10)

When calling:


I'm using phalcon 1.3.1 in php 5.5.10 on osx mavericks using the default dependency injector.


Segmentation faults like this are not a result of something you've done. This is a bug in Phalcon - you should post this on GitHub.


I have raised the issue here

edited May '14

Cool, but I have seen a lot of reports concerning security->hash (since 1.3.x).. (Isn't this the same?) (All were related to Windows though...)


You may mean this one #2277.

I don't know if this is the same.