Install halts on Ubuntu 14.04

So I followed the steps to install phalcon and can't get passed ./install.... It just stops at the action below...

i currently have a LAMP setup and cloned the project int my root directory, is that wrong?

config.status: executing libtool commands
/bin/bash /root/cphalcon/build/64bits/libtool --mode=compile gcc  -I. -I/root/cphalcon/build/64bits -DPHP_ATOM_INC -I/root/cphalcon/build/64bits/include -I/root/cphalcon/build/64bits/main -I/root/cphalcon/build/64bits -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib  -DPHALCON_RELEASE -DHAVE_CONFIG_H  -march=native -mtune=native -O2 -finline-functions -fomit-frame-pointer -fvisibility=hidden   -c /root/cphalcon/build/64bits/phalcon.c -o phalcon.lo 
libtool: compile:  gcc -I. -I/root/cphalcon/build/64bits -DPHP_ATOM_INC -I/root/cphalcon/build/64bits/include -I/root/cphalcon/build/64bits/main -I/root/cphalcon/build/64bits -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -DPHALCON_RELEASE -DHAVE_CONFIG_H -march=native -mtune=native -O2 -finline-functions -fomit-frame-pointer -fvisibility=hidden -c /root/cphalcon/build/64bits/phalcon.c  -fPIC -DPIC -o .libs/phalcon.o


It probably does not have enough memory to compile Phalcon from build. Could you try compiling from ext?

cd cphalcon/ext
export CFLAGS="-O2 -finline-functions -fvisibility=hidden"
./configure --enable-phalcon
sudo make install

I'm getting the same thing using a 512 MB VPS. I've tried the above method and tried changing GCC limit. Any ideas?