We have moved our forum to GitHub Discussions. For questions about Phalcon v3/v4/v5 you can visit here and for Phalcon v6 here.

Phalcon 1.2.0 released!! [1.2.1 also available]

This new release of Phalcon, contains several new features (mostly requested by the community), bug fixes and various performance improvements.


1.2.1 update: https://blog.phalcon.io/post/56248847111/phalcon-1-2-1-released


"The best balance of speed and functionality”

I like it. :)

please update roadmap on github

Great work! Time for me to explore new things :)


I tried to be patient :) but will there be an x64 win dll version for php 5.5 vc11?

@doit76 Roadmap updated.

@posthy Compiling DLLs is not as easy as it might sound. For 5.5 I have to set a new VPS machine with Windows 7 or higher (which I do not have a copy of) install VC11 and then compile it. I was looking to purchase a cheap copy but my attempt failed. Despite the fact that you can compile the DLLs yourself using the current code base (see documentation / internals documents) I will try to find something and get 5.5 DLLs


Great job guys! Very interesting project.

How about integrating docs generated in https://test.phalconphp.ru/ to the official phalcon 1.2.0 reference docs. It is easier to browse.

Оле оле оле оле. PhalconPhp чемпион!!! Just propose the motto: "The best speed and great functionality”

Amazing, thanks! :)

@jeffreycahyono That is one of the next things to do - make the documentation even better and available in more languages. The same goes for the website.

Great news! However, sometimes there is lack in documentation regarding many params. Hope it will be updated! Молодцы!


Amazing project! Does anyone have a MVC workflow diagram?


Is it safe to use 1.2.1 for production or should I wait a while? I use 1.2.1 (today compilation) on dev and it seems to be ok. I need to use file arrays and this compilation support it.

i can't download Phalcon 1.2.0 - Windows x64 for PHP 5.3.9 (VC9) :(

@vietkleii I just tried and it downloaded just fine. Could you please try a different browser or clear your browser cache?

@doit76 1.2.1 is unofficially production ready but it is up to you if you want to download it and use it. I am going to compile a fresh set of DLLs in the next hour or so.

@Nikolaos Dimopoulos: Many thanks..! when do u finish it to upload? Because i need urgently..!

1.2.2 branch avaliable! Yaay!

@jeffreycahyono the master branch has 1.2.1. We are going to merge 1.2.2 tomorrow in the master branch which contains several bug fixes :)

cool, right on guys!

so, what about 1.2.3 version which was merged to master?