We are moving our forum in GitHub Discussions. For questions about Phalcon v3/v4 you can visit here and for Phalcon v5 here.

Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Model save() not save data

there is code:

    $email = $this->request->getPost('email', 'email');

    $user = users::findFirst(array(
        "email = :email: AND active = 1",
        "bind" => array('email' => $email)

    if ($user != false) {
        $newPassword = $this->generatePassword(mt_rand (8, 12));
        $hashedPassword = password_hash($newPassword, PASSWORD_DEFAULT);

        $user->password = $hashedPassword;


        foreach ($user->getMessages() as $message) {
            echo $message, "\n";


but the data in the column "password" are not updated!

although var_dump($user->save()); returns "bool(true)" and does not display any messages

tell me, what's wrong?


What happens if you try to update another field?


maybe "password" field is in your model's "skip columns" lists.

check skipping-columns