Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

[SOLVED] Issue when creating a project.

It seems that I am having some sort of trouble using DevTools.

When I create a project (let's say my project is called 'Test') in my localhost directory, DevTools will set up the folders and the proper structured project directory. However, when I type 'localhost/Test' in my navigator a "server error" screen will show up.

This doesn't seem to be a problem of my webserver's config, since if i manually create a directory/file within my localhost, let's say 'localhost/debug/debug.php', and access it through my browser, whatever content debug.html has will show up.

I am using Phalcon DevTools 1.2.3 with PHP 5.4.9 over Apache2 (installed alongside Zend engine 2.4.0.). My OS is Ubuntu 13.10.

Cheers and thanks in advance

Can you show your logs?

edited Oct '14

Here is my apache's error log for my just created project called test3:

[Tue Aug 20 08:39:04 2013] [error] [client] PHP Fatal error:  Class 'Phalcon\\Config' not found in /var/www/test3/app/config/config.php on line 3
[Tue Aug 20 08:39:17 2013] [error] [client] File does not exist: /var/www/favicon.ico
[Tue Aug 20 08:39:45 2013] [error] [client] File does not exist: /var/www/favicon.ico
[Tue Aug 20 08:40:15 2013] [error] [client] File does not exist: /var/www/favicon.ico
[Tue Aug 20 08:40:17 2013] [error] [client] File does not exist: /var/www/favicon.ico

You dont have phalcon installed or loaded please follow the install directions


Problem solved, actually it was the same problem as in

So many php.ini files can be confusing.

Anyway, thanks!