Mac Ampps Installation Problem

Well I installed it and put the "" down on the bottom of php.ini but it's not showing in the php info and I try to pick it from the php extension window in the php tab from the ampps control panel and it does not keep check marked. Any help would be awesome thanks.


Was the extension compiled with the php bundled with Ampps? Are some insightful info in the logs?

Thanks for the reply I did get a error message in the log

PHP Warning: PHP Startup: Unable to load dynamic library '/Applications/AMPPS/php-5.4/lib/extensions/ext/' - dlopen(/Applications/AMPPS/php-5.4/lib/extensions/ext/, 9): image not found in Unknown on line 0

I read more on your forum and you said that phalcon cannot be compiled with ampps or xampp.

So I tried to compile it on homebrew install then copy it over to the ampps php install it still doesn't work. One thing I do notice in the extension folder theres a .so and a .a file so with phalcon I only get a .so file and no .a file?

Also I tried to see if my Web Hosting company could succeed in installing it but they ran in to problems to with the cPanel install. They also have a error message to for you.

./install Configuring for: PHP Api Version: 20100412 Zend Module Api No: 20100525 Zend Extension Api No: 220100525 /usr/share/automake-1.11/Automake/ line 23:

This Perl hasn't been configured and built properly for the threads module to work. (The 'useithreads' configuration option hasn't been used.)

Having threads support requires all of Perl and all of the XS modules in the Perl installation to be rebuilt, it is not just a question of adding the threads module. (In other words, threaded and non-threaded Perls are binary incompatible.)

But they did say your instructions were so simple. But they encountered issue with Perl.

Thanks for the support.

try the full path in your php.ini, it worked for me. something like:


Thanks for the reply @screenas I tried to do that but it didn't work

Did you build phalcon on ampps php 5.4?

[warn] NameVirtualHost has no VirtualHosts PHP Warning: PHP Startup: Unable to load dynamic library '/Applications/AMPPS/php-5.4/lib/extensions/no-debug-non-zts-20100525/' - dlopen(/Applications/AMPPS/php-5.4/lib/extensions/no-debug-non-zts-20100525/, 9): no suitable image found. Did find:\n\t/Applications/AMPPS/php-5.4/lib/extensions/no-debug-non-zts-20100525/ mach-o, but wrong architecture in Unknown on line 0

You don't get this error? How did you install everything did you do anything different?

Thanks for the help.

That problem is because runs as a 64bit version, but you need 32bit. You can check it in terminal with the lipo function.

Compile Phalcon with AMPPS (used php 5.5):

Check in terminal if php points to /Applications/AMPPS/php-5.5/bin/php: php which php

then i tried this (from:

cd cphalcon/build/32bits
export CFLAGS="-O2 -fno-delete-null-pointer-checks -finline-functions -fomit-frame-pointer -march=core2 -m32"
sudo make clean
sudo phpize --clean
./configure --enable-phalcon
sudo make
sudo make install

hope it will help and sorry for my bad english

I'm going to try it thankyou for the help. I upgraded to the new ampps and now it keeps on having a internal error on the ampps page so I'm trying to fix it to. By the way you have good english I can understand you perfectly.

Whoo fixed the Internal Server Error.

I tried it and I got a little bit different error this time

Warning: PHP Startup: Unable to load dynamic library '/Applications/AMPPS/php-5.5/lib/extensions/no-debug-non-zts-20121212/' - dlopen(/Applications/AMPPS/php-5.5/lib/extensions/no-debug-non-zts-20121212/, 9): no suitable image found. Did find: /Applications/AMPPS/php-5.5/lib/extensions/no-debug-non-zts-20121212/: not a file in Unknown on line 0

Might be getting little further.

Thanks so much for your help.

I got it I had to go in to the php.ini there's two for some reason. You don't change the php.ini file though the ampps control panel you have to go to the directory actually and go to the real php.ini. Thanks for the help. @phalcon you should put that solution up on the install instructions on the website for people to know about because this is how you install it on ampps. Thanks @screenas.

My webhost perl problem still exists though for cPanel hope we can get this fixed to @phalcon.

I found unfortunately, the version of Perl that cPanel installs and manages does not have support for Perl threads and there is no option to change this. So phalcon can't be installed on cPanel.


It seems that automake needs perl, did you tried using macports?

I got it installed on my ampps with thanks to @screenas but my webhosting company says that cPanel does not support Perl threads.

Thanks for the support.


Do you know what OS is running on the cPanel machine?

The server is running CENTOS.


Could you try to compile Phalcon on similar machine and then copy the "so"?

I don't have another server that is CentOS. The hosting company said that cPanel doesn't support Phalcon so the only way you can put Phalcon on cPanel is for cPanel to release a update to support it. Because they said that cPanel doesn't come with Perl Threads at this point.

Thanks for the support @Phalcon

vote for Phalcon (;

I am a bit confused. Perl Threads you need only to Compile/Install Phalcon, but not to run it.. right?

@screenas Ya I think you need perl threads for install unless some way you need it to run Phalcon? I voted hopefully cPanel listens. Because they put allot of things that are important always on the back burner.

Not sure. I thought, you need perl only to compile. If you have a compiled version, you can copy it and it would work out of the box, when it is the same architecture? I will play tomorrow with Phalconphp on my Test Server (CentOS, ISP Config). If it will work, I can upload the and note which architecture I'm using.

Ok cool thankyou @screenas I think your right on compile only.