Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Problems with AWS beanstalk and Phalcon


I have some problems with my Phalcon application and deploying it to AWS beanstalk.

My App works perfect on my local machine with apache and mysql, but when I deploy it to AWS I get blank pages when accessing two of my controllers and two actions in specific. It shows blank pages all the time and the error log shows:

[Sun Feb 02 22:33:25.956930 2014] [core:notice] [pid 29138] AH00052: child pid 29606 exit signal Illegal instruction (4) [Sun Feb 02 22:33:43.983699 2014] [core:notice] [pid 29138] AH00052: child pid 29607 exit signal Illegal instruction (4) [Sun Feb 02 22:34:13.023901 2014] [core:notice] [pid 29138] AH00052: child pid 29608 exit signal Illegal instruction (4) [Sun Feb 02 22:34:45.076915 2014] [core:notice] [pid 29138] AH00052: child pid 29604 exit signal Illegal instruction (4)

Has any of you seen something like that, both selects multiple rows from the database, but it works on dev. When looking at the server, it cuts the connection before serving any KB.

I found that Paginator did the different, can it be while AWS beanstalk is using php 5.5 ?

If I use Paginator it fails with the error above, do others have the same problem?

@robert-mygind can you open an issue in Github if you haven't done so already? If you also accompany it with a failing test it would be great!!

i'm having the same issue on AWS beanstalk PHP 5.5... what is the resolution?

exit signal Illegal instruction (4)

edited Dec '14

Try compiling this way:

cd cphalcon/build/safe
export CFLAGS="-O2 -fvisibility=hidden"
./configure --enable-phalcon
sudo make install


I can confirm, I also had to build a safe build.

I used CFLAGS="-O2 -g -fomit-frame-pointer -DPHALCON_RELEASE" however (

@phalcon how much less optimized is a 'safe' build? Currently I am (still) in a testing environment, but for production I'd rather have an optimized build of course. (But stability is the most important of course.)

edited Dec '14


I rebuilt my environment and follow the five lines of commands,

when I execute "make" it gets "make: *** No targets specified and no makefile found. Stop."

I then move on to the next "sudo make install" and it gets "make: *** No rule to make target `install'. Stop."

and I have a few more questions about the Phalcon framework:

could you please help?

thanks in advance


i found one of your post:

am i missing those lines?

"sudo make clean" gives "make: *** No rule to make target `clean'. Stop."


I execute "./configure --enable-phalcon", and then "make" and then "sudo make install", it shows no error.


I've corrected the installation instructions