SIGSEGV signal 11 in 1.3.x

I've been going at this for hours trying different versions and I can't seem to get this working. It seems that whenever I do a post request to the server I get this error for 1.3.x Version 1.2.6 works great. This code also works great on my laptop, butn ot on this CENTOS 6.5 server. Got any ideas?

gcc (GCC) 4.4.7 20120313 (Red Hat 4.4.7-4)


[07-Jun-2014 23:19:14] WARNING: [pool www] child 5194 exited on signal 11 (SIGSEGV - core dumped) after 107.461694 seconds from start
[07-Jun-2014 23:19:14] NOTICE: [pool www] child 5211 started


Jun  7 23:19:14 li163-202 kernel: php-fpm[5194]: segfault at 18 ip 000000000058d249 sp 00007fffabfa3470 error 4 in php-fpm[400000+323000]
Jun  7 23:19:14 li163-202 abrtd: Directory 'ccpp-2014-06-07-23:19:14-5194' creation detected
Jun  7 23:19:14 li163-202 abrt[5210]: Saved core dump of pid 5194 (/usr/sbin/php-fpm) to /var/spool/abrt/ccpp-2014-06-07-23:19:14-5194 (148742144 bytes)
Jun  7 23:19:15 li163-202 abrtd: Package 'php55u-fpm' isn't signed with proper key
Jun  7 23:19:15 li163-202 abrtd: 'post-create' on '/var/spool/abrt/ccpp-2014-06-07-23:19:14-5194' exited with 1
Jun  7 23:19:15 li163-202 abrtd: Deleting problem directory '/var/spool/abrt/ccpp-2014-06-07-23:19:14-5194'


Phalcon 1.3.2 was announced here in the forum. I think your best bet is to wait until it gets released (probably this week) and try with the new version.

link to the announcement:


I don't know, but have you tried to compile & install a safe build? e.g.:

(ps; if you add a newline before your fenced code blocks, they will render properly.)

edited Jun '14

@phantos; I guess you can already compile 1.3.2 (final) safely (master already reflects that version). As I understand it, only the official announcement has te be written/ put online + Windows dll's.

@renskii I just tried that and no avail. The issue remains. Is there a way to figure out what the issue is? Any debug? If I can at least figure out what method its calling, maybe I could try to avoid it?

Interesting enough I just removed opcode cache and everything works now.


Regarding building 1.3.2 it seems I was mistaken. /build still had to be re-generated. @phalcon updated master last Monday.